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New Features 

Time & Sales Window 

 Filter for size feature added  
 Added ability to “Show Qty in 100s”  
 Added “Always on Top” option 

Mini OE Window 

 Provides a new option to set the default focus value. Users can decide which field 
will have the focus when they change a stock or set focus on an existing MM 
window. This can be controlled using Setup->Mini OE from any Market Maker 
window 

 Added a new button to HIDE:ON or HIDE:OFF orders. This will send hidden 
orders to routes that support it. 

 Added a “Cancel All” button for selected Stock button 
 Added “Lock”  destination button – that will lock the entry in the destination 

field 
 Added “LST-EXCH” as a destination that will send orders to the listing exchange 

for the particular stock. This will also be the default route. 
 Custom Order Entry buttons for the Mini OE window. These buttons will appear 

in a new panel below the Mini OE window and allow single click order entry 
based on preconfigured settings (Side, Destination, Price). They can be 
configured using Setup->Mini OE from any market maker window 
 

Boardview 

 Added “Alerts” (They can also be opening by click on “Open->Alerts” from the 
main Graybox window) 

 Alerts can be set by entering a symbol in the Boardview window and right 
clicking and selecting the “Set Alerts” menu item 

 Users can use the “Set Alerts” dialog box to send the alert condition(s) 
 The behavior when alert is triggered can be controlled by clicking on 

“Setup->General”. Currently, users can enable an audio alert or\and 
flashing of the row or\and messages sent to the Notifier window 



Desktop API 

 Performance improvement during stress conditions when a large number of 
orders are sent quickly 

 Send an explicit “Subscribe” not needed if sending orders for a symbol. Explicit 
subscription should only be used judiciously, and should be followed by 
Unsubscribe eventually. 

 Added a new message type to unsubscribe to a symbol, if manually subscribed 
earlier 

 When requesting all current positions, the  GBXCTRLLib::MSG_GBX_POSITION 
with Symbol = “”, and Qty = 0 will signify End of transmission i.e. all the position 
information has been sent. 
 

Compliance & Risk 

 Added support to identify IPOs. A check has been added  to prevent sending of 
Market Orders before an IPO has opened 

 Fixed an issue that could prevent the self-crossing prevention logic from 
applying at times. 

 Plugged loop hole that allowed sending market orders when no level1 data is 
available (and no risk calculation can be made) 

 Fixed the issue where the users could flip positions by over covering when FBP 
or BP is not available and they send covering trades that are equal to their 
position size 

 MOC orders after 3:45 PM cutoff – Will treat originating orders as a covering 
trade if the there is a MOC order floating beyond the 3:45 PM cutoff 

 Clearly Erroneous order check – Will block orders that are 25% away from the 
inside market  

 Fixed loop hole that could be exploited to go over assigned buying power – while 
over covering positions. Now attempt will be made to cancel previous covering 
orders if placing a new covering trade – if Floating BP becomes zero 
 

Misc & Others 

 Position Monitor: Changed name of field “Buying Power” to “BP Avail” 
 Swipe Keys: Added a new Swipe Based On – “Inside Mkt – Add”. This can be 

used to configure swipe keys that help in adding liquidity or joining the bid/ask 
 Market Clock – Will display when the market is “CLOSED – PRE MKT” closed 

and “CLOSED – POST MKT”. Also, will display when the MOC Cutoff time has 
elapsed 

 Market Maker Window: Filter for size is enabled for the Sales (Prints) display 
in the MM window. Select “Setup->Prints” to set the minimum print size to 
display 



 Reserve Qty: Added ability to Hide All and Show 100, Show 200, Show 300, 
Show 400 and Show 500 buttons in Set Reserve Qty dialog box for single click 
modification 

 RASH destination has been renamed as NSDQ 
 Market Maker Window: Ignores for Post Mkt Hours – Users can ignore market 

participants from displaying in the MM window (that will only be active during 
post market hours). Right click and select “Ignores for Post Mkt Hrs” from each 
MM window and enter the MPID to be ignored. Keep in mind, the old ignores list 
is active for all times. 

 Charts – enable\disable the 3-D mode for the charts display 
 MM Order Entry window – Added an option to display buttons in multiple lines 
 Default Step Size: Added ability to save “Step size” per stock using Trading 

Options. If a step size is saved per for a stock, all order entry windows – MM 
Order Entry Wnd, Mini OE Wnd, Listed Trading Wnd, ECN Order Entry Wnd and 
the Preference Wnd will be set to the default on changing symbols (Saved as part 
of the local layout. This is current not saved with the roaming profile) 

 Always On Top: Added the option to enable\disable “Always On Top” for the 
Active Orders window, Positions Monitor, Market Clock, Execution Ticker, 
Notifier window, Hedges & Locates Monitor (Right click and check\uncheck 
“Always On Top”) 

 Ability to turn off the Menu, Toolbar, Title bar and Status bar for the Active 
Orders window. (right click and select Setup) 

 

 

Bug Fixes 

 Fixed problem displaying negative MACD values in Charts 
 Fixed issue saving “Enable Point & Click to Set Price” for the Setup->Order Entry 

window. This controls mouse based price update for the Market Maker Order Entry 
window and the Preference window 

 Fixed memory leak with the Times & Sales window 
 Fixed issue reported with “Avail BP” display in the Position Monitor 
 Fixed bug with Market Clock prior to the Open 
 Improved display when a stock has no bid or/and ask quotes 
 Removed “Trade Assignment” functionality 
 Does not connect to “TV (INET Book) Server” if not entitled for INET Book 
 Auto reject Locate feature request will only work if the Min price is > 0.00. Earlier it 

was treating 0.00 as a valid min price and rejecting locates automatically. 
 Fixed bug with loading symbols with non-alpha characters such as Preferred in the 

Boardview window via a file 
 Added support to handle BBSS-BoothIds from line handlers from the order status 

message 



 Manual Order Entry window - Possible fix to a bug where an entered limit price is 
overwritten, at times,  by inside market,  

 Fixed the issue where the BP Avail field in the Positions Monitor was not updating 
during RMS updates 

 Desktop API - Fixed crash on disconnect 
 Fixed issue with quote entitlements that allows viewing of entitled book quotes 

even if not entitled to depth feeds from the listing exchange. E.g. if a user is not 
entitled for NASDAQ level2 but entitled for BATS book, the user can view the BATS 
book. 

 Optimized the Active orders window to improve peak time performance 
 Prevents multiple BP checks on receiving multiple market open/close messages 

from various exchanges. Only one check is done now 

 

 

v3.5.1 SP9 

08/01/11 

 Fixed a bug loading KeyMap Config dialog 

v3.5.1 SP8 

08/01/11 

 Fixed a bug with bad EDGA book quotes from backup quotes 
 Added support for SGNT network – for ASNX and LTCO 
 Bug with default qty resetting in the Market maker window fixed 
 Bug with sending two orders from the BBSS orders in Mini OE window fixed 
 Added handling for BATS book flush 
 Fixed issue with imbalance updates during times of minimal quote activity 
 Fixed bug with RMS instructions, not cancelling all non-covering floating orders when CTO 

mode set. 

 

v3.5.1 SP7 

06/23/11 

 Limit On Close orders bug when sending LOC orders to NYSE after cutoff time fixed.  
 



 Order type Limit On Close and Market On Close can be used exactly the same way for 
ARCA, RASH (NSDQ), NYSE, NYSE-AMEX, HDOT, BELZ by using just the drop down in the  
MiniOE or MM Order Entry windows. (Earlier ARCA needed explicit Time In Force values). 
 

 Added ability to “drag and drop” a Symbol using a mouse from a Boardview window to 
any Market Maker window or Time & Sales window. This will work even if the two windows 
are not linked. 
 

 Time & Sales window color schema reflects on the entire row and not just the price 
column 
 

 Time & Sales window fixed bug with the saving of  column widths in the layout 
 
 

 Swipe keys – fixed a possible cause of freezing when using the “Inside Market – Take” 
Swipe based on mode. 
 

 BATS MPP – Mid Point Peg Orders are supported at the client level. They are available via 
Trading options or using the MiniOE destination drop down and hot keys. (Not immediately 
available for use as Server upgrades are needed) 
 

 Bug with viewing Imbalances (Column Imb) in the Boardview window fixed 
 

 Warning added when exiting Graybox with Order Floating. The warning box allows users 
the option to cancel all floating orders at the close. 
 

 Speeded up the loading of the KeyMap Config window, for the first time 
 

 Support for NSDQ Imbalances.  Users need to have INET Full Book (NSDQ Total View) 
entitlements to view them 

 

v3.5.1 SP6 

06/14/11 

 Exempted floating BBSS orders from getting cancelled due to the oversell prevention 
algorithm 

 Desktop API – Fixed a bug when proactively subscribing for stocks 
 Fixed a bug with using the “Toggle Order Type” hot key for the Mini OE window 
 Added new pre-configured hot keys for the Mini OE window 

o They can be configured to a hot key of choice using the KeyMapConfig dialog 
(Market Maker window tab) 

o The new keystrokes are as follows: 

Market Maker Window 
 Menu Group SubGroup Function 



MiniOE                   Orders                   BBSS                     Set BBSS - 3L Buy @ Inside Ask                     

MiniOE                   Orders                   BBSS                     Set BBSS - 3L Buy @ Inside Bid                     

MiniOE                   Orders                   BBSS                     Set BBSS - 3L Sell @ Inside Bid                    

MiniOE                   Orders                   BBSS                     Set BBSS - 3L Sell @ Inside Ask                    

MiniOE                   Orders                   ARCA                     Set ARCA MPL Sell @ Inside Ask                     

MiniOE                   Orders                   ARCA                     Set ARCA MPL Buy @ Inside Ask                      

MiniOE                   Orders                   ARCA                     Set ARCA MPL Buy @ Inside Bid                      

MiniOE                   Orders                   ARCA                     Set ARCA MPL Sell @ Inside Bid                     

MiniOE                   Orders                   EDGA                     Set EDGA MPM Buy @ Inside Ask                      

MiniOE                   Orders                   EDGA                     Set EDGA MPM Buy @ Inside Bid                      

MiniOE                   Orders                   EDGA                     Set EDGA MPM Sell @ Inside Ask                     

MiniOE                   Orders                   EDGA                     Set EDGA MPM Sell @ Inside Bid                     

MiniOE                   Orders                   EDGX                     Set EDGX MPM Buy @ Inside Ask                      

MiniOE                   Orders                   EDGX                     Set EDGX MPM Buy @ Inside Bid                      

MiniOE                   Orders                   EDGX                     Set EDGX MPM Sell @ Inside Ask                     

MiniOE                   Orders                   EDGX                     Set EDGX MPM Sell @ Inside Bid                     

  
 Added new pre-configured hot keys for Cancelling Orders 

o Four new keystrokes when configured will allow users to cancel the oldest buy 
order (for any stock), old buy order for selected stock, oldest sell order (for any 
stock) and oldest sell order for selected stock. (Graybox tab) 

o The new keystrokes are as follow: 

 

 

 

  

Graybox 
   Menu Group SubGroup Function 

Execute                  Cancel Order                                      Cancel Oldest Buy                                  

Execute                  Cancel Order                                      Cancel Oldest Sell                                 

Execute                  Cancel Order                                      Cancel Oldest Buy Selected Stock                   

Execute                  Cancel Order                                      Cancel Oldest Sell Selected Stock                  



 

v3.5.1 SP5 

06/06/11 

 Exempt orders routed to BBSS – Floor broker from the pre-order  wash sale 
prevention logic 

 Fixed bug with entering Preferred Stocks in the Boardview window. 

v3.5.1 SP4 

05/20/11 

 Allows HBCL MPID traders to use the HOLD ETB list 
 New feature that will allow the Logon servers to make temporary intraday changes in 

BP/FBP using BP/FBP factors. This will preserve the original values for BP/FBPs set for the 
traders.  

 Allow resizing of the Trading Options dialog 
 Bug with Open Orders in the level2 display disappearing on a quote server reconnect fixed 
 Send Account ID in addition to the BRSQ in the messages to the order routers 
 Fixed issue with risk entitlement setting of “Max # of positions held at one time” 
 API: fixed crash on sending orders for known symbols, problem with MOC orders and 

sending of NYSE orders 

v3.5.1 SP3 

04/20/11 

 Added a new feature to automatically trigger a Graybox Client based Trailing Stop on 
Entering or Adding to a Position. 

1. To enable this, right click on the Main Graybox window (Active Orders window), 
select “Setup->Trailing Stops” and enable the “Auto Trigger Trailing Stops On 
Entering Positions” check box. 

2. The settings used for this is the same as the settings for the “Direct Trailing Stop Hot 
key” 

3. This feature is available only during market hours and only during the process of 
entering a position or adding to an existing position. This is not available when 
carrying over positions between multiple Graybox sessions or when carrying 
overnights. 

4. The trailing stops reduce in qty as the positions are covered. They are cancelled 
completely when the position is closed. 

5. The trailing stops are active only during a Graybox session. They cancel on close and 
are not automatically reactivated on a restart. 

 Fixed a possible loophole that could lead to short orders being sent for Hard to Borrow 
stocks. This could happen randomly for API users as well those using Trailing stops. 



 Fixed bug with Reflash Orders functionality. The Reflash Orders feature now uses 
Cancel\Replaces for ECNs\Exchanges that support it. For those that don’t, it cancels and 
then sends a new order with a different limit price. 

 Desktop Execution API – Will reject orders if the API user sends an order with a duplicate 
BBID for the session. The API users are asked to send Orders with unique BBID per session. 
 

v3.5.1 SP2 

04/06/11 

 Added new route for CSFB – PATHFINDER 
 Added “INTRADAY SHORT ONLY” warning for Stocks designated as Threshold Security. 
 Bug with Boardview column order when loading from a csv file fixed 
 Graybox Desktop API: Issue with GrayboxID not getting correctly passed back fixed. 

v3.5.1 SP1  

03/14/11 

 Fixed a loop hole that could potentially allow a trader to breach the Floating exposure 
limits, when using the SuperECN key 

 Fixed bug with Locates->Auto Reject feature 
 Crash when trying to manually find the status of an order – when there are no order floating 

– fixed. 

 

v3.5.1  

03/10/11 

 Fixed issue with the MiniOE Window that could update the limit price even if LIVE mode 
was turned off. 

 Allows users to query the Current Status of a floating order. (Right click on the floating 
order in the Active Order Window and select the “Check Order Status” Menu item. The 
result of the query is available in the Notifier window as well as the status tray notifier pop 
up. 

 On logging on to system, Graybox attempts to figure out the status of the orders that were 
floating from the previous session. The ones that are not active are removed from the Active 
orders window 

 Allows a new Graybox session, on a new machine, to show active orders from a previous 
session on another machine. 

 Bug with slowing down of Market Clock, when running for a long time, fixed 
 Added support for symbols that are greater than 6 characters including suffixes 
 Fixed issue with stuck quotes for ECNs (being ignored by the MM window) but not by 

various Order entry windows 



 Swipe keys: Added new option for the Swipe keys to remove liquidity for ECNs. Also, added 
missing ECNs from the Swipe keys such as XBOS, NQPX, DTTX, etc. The Swipe keys options 
can be set by right clicking on the main GB window and selecting Setup->Swipes/Delta 
Keys.  The hotkeys can be assigned using KeyMapConfig dialog.[Note: There are 6 sets of 
Swipe keys that can be configured independently] 

1. The various options for Swipe Based On is as follows:  
1. Swipe ECN Book – Send Limit Order at Swipe Factor +/- Best Exchange Bid 

(for Buys) or Offer (for Sells), if quote is detected for the ECN or Exchange.  
2. Level1 Inside - Send Limit Order at Swipe Factor +/- Best Level1 Best Bid 

(for Buys) or Offer (for Sells) 
3. Inside Mkt Consolidated - Send Limit Order at Swipe Factor +/- Best Level2 

Displayed Best Bid (for Buys) or Offer (for Sells) 
4. Negative Inside Mkt - Send Limit Order at Swipe Factor -/+ Best Level2 

Displayed Best Bid (for Buys) or Offer (for Sells) [Will put the order below 
the best bid/offer displayed for buys/sells resp.] 

5. Inside Mkt-Take - Send Limit Order at Swipe Factor +/- Best Level2 
Displayed Best Bid (for Sells) or Offer (for Buys) –[Aim is to remove 
liquidity] 

2. Added new values for Swipe factor e.g. 0.06, 0.07, etc 
 

 Inside BBO quotes from the ECNs\Exchange for which book data is available and subscribed 
is ONLY suppressed once we actually start getting book data for them. E.g. PSE quotes are 
visible till we start getting ARCA book depth. Once the client gets data for ARCA book, PSE 
quotes are automatically suppressed 

 Cross\Wash prevention logic is not enforced on an existing floating MOC\LOC order. 
 Fixed issue with the saving of the “View->Mini Order Entry” setting for each Market Maker 

window 
 Added feature to view floating orders in the Level2 quotes montage. They can be viewed 

either as aggregated at each price level or displayed individually. 
o To enabled this feature (disabled by default). Go to “Trading Options->Orders in 

Level2 Wnd (bottom left) 
o Orders can be cancelled by clicking on the ‘red cross” icon for that displays each sets 

of orders or individual order in the level2 display. 
 Support for BYXX (BATS-Y) exchange 
 Fixed bug with entering symbols in Boardview when loading symbols from a layout 
 Added formatting for Qty and Exposure columns in the Positions monitor 
 Added new Mini OE setup that can be used to control the behavior of the Mini OE window. 

From main Graybox window, select “Setup->Mini OE” 
 Increased the number of symbols that can be saved for the Default Qty list box in Trading 

Options 
 Fixed bug with changing Basket Qty in the Boardview when running in Basket trading 

mode. 
 Spread Protection for Direct Super ECN Key – If a value is set for this via Setup-

>SuperECNKey, it will not send SuperECNKey orders if the spread of a stock is greater than 
specified. Setting a value = 0.00 (default), will disable this feature. 

 Will use close out “tokens” before auto close outs. In the rare event when no close out token 
is available, the auto close out will be disabled. A message will ask the trader to close out 
position manually. 
 



-------------------------------------------------------------------------------------------------------- 

V3.5.0 SP7 

11/22/2010 

 Fixed a couple of loopholes with self-cross prevention logic 

v3.5.0 SP6 

11/03/2010 

 Added ability to display a flag in the Market maker window, when a stock hits the 10% 
circuit breaker and the Bid Price test for short sales is enabled for that particular stock ( Reg 
SHO 201) 

 Traders on Compliance Mode = ‘SHORT ALL’ will be able to cover using long positions using 
long sells for stocks that hit the Bid Price test circuit breaker 

 Fixed issue with loading of positions > 100 different symbols 
 Removed comma formatting for Positions monitor that was causing some incorrect display 

of $PnL column 
 

v3.5.0 SP5 

10/28/2010 

 Fixed the issue with the display of large Buying Power values in the Summary Section of the 
Position Monitor 

 Alignment issue with the Price field in the Listed Trading window fixed. 

 

v3.5.0 SP4 

10/25/2010 

 Fixed issue with saving some settings to the database via the logon server 
 Improved speed of level 1 update when changing new stocks especially if the stocks are 

slow moving. 
 Added support for BYX (BATS Y exchange) via backup quotes 

v3.5.0 SP3 

10/20/2010 

 Fixed bug with MM Order Entry buttons configuration getting lost on changing symbols 
 Added “auto fit” resizing to the Market Clock window 



 “Caption” off in the Market Clock window is being saved in the layout. 
 Added basic execution support for NQPX and FLOW once its available it the backend 
 Added entitlement check for the Desktop API 
 Fixed issue with Client status update when GB charts are used from the layout 
 Enabled smart opening of multiple connections to the historical database based on the 

number of charts in a layout. This will reduce unnecessary connections to the historical 
server for users who do not have charts. 

 Fixed bug with Logon server reconnect on certain machines 
 Improved efficiency of the Active Orders window by ignoring updates for ‘V’ messages 
 A couple of stability issues with GB charts fixed 
 Notifier window bug when switching layouts fixed 
 Mini OE window – hot key for toggling order types (e.g. limit, market etc) added. (Use 

Keyboard Config-> Market Maker window tab->Order Entry->Toggle order types) 

v3.5.0 SP2 

09/29/2010 

 Added new hot key to toggle between various ARCA routing modes for the Mini OE and the 
MM Order Entry windows 

 To configure the hotkey, use KeyMap Config (Marker Maker Window tab) and set 
the “Mini OE -> Toggle ARCA Routing Mode” hot key to a desired keystroke 

 Fixed wrong caption for the ARCA Routing Mode in Trading Options 
 Added verbose error description for database related error messages coming from the 

logon server (so you don’t get the empty message box with the ! mark) 
 Switched location of DTTX and CBSX buttons for the Listed Trading window 
 Fixed issue with the saving of the bold font in the layout in some machines/OS. This should 

be backward compatible – however, if the font is not bold – and you saved it as such – just 
saving the layout will fix it for good. 

v3.5.0 SP1 

09/21/2010 

 Support for CBSX 
 Will allow the GB client to send orders to the CBSX exchange once the backend 

servers are available 
 Initially support 3 routing types: 

 CSBX DEFAULT – default routing as per the exchange 
 CBSX ONLY – will not route out of CBSX 
 CBSX MPC – will send orders for the CBSX “Mid Point Cross” 

 Fixed issue of slow loading of layouts with multiple chart windows with the same symbols 
 Fixed issue with connecting to secondary IP addresses when all the primary IPs are not 

working 
 Fixed problem with “Temporary Position Entry” in 64-bit machines 
 Bug with “Reset All Secondary Connections” when connected via logon servers fixed. 
 Issue with repeat keystroke behavior being disabled when “PAGE UP” or “PAGE DOWN” 

keys are set for order entry purposes fixed 



   

v3.5.0 

09/03/2010 

 

 New “Time & Sales” window 
 This window can run linked from the MM window, from the main GB window 

(linked with the MM window with focus) or unlinked (from the main menu)  
 Automatically starts on live mode  
 Provides historical tick data – going back to 5 days [Backup Quotes->Historical 

needs to be checked in System Configuration]  
 Provides inside bid/ask changes 
 Allows users to filter by Exchange ID and condition 

 New Mini Order Entry Window 
 Allows a simple point and click interface for order entry  
 All destinations are available in a single drop down  
 Click on the MM window changes the price, based on where the mouse was clicked 
 Live mode can be toggled to enable live updates as the market changes  
 Hot keys available to set the destination, side of the market, 

incrementing/decrementing prices, toggling between controls 
 Charts 

 Zoom in and zoom out functionality – that automatically changes the “show last” 
functionality  

 Background processing of historical data to speed up data update on changing 
stocks  

 Throttling in tick charts to prevent CPU usage on data bursts  
 Horizontal and vertical trend lines added 
 Hotkeys added for charts –  

 +/- : zoom in and zoom out  
 1,2,3…0 – changes the time interval for interval charts (bar, candlestick) 

 Open-Close Candle chart type  
 Optional toolbar with commonly used functions  
 A new color settings menu 
 Optimization for faster historical access  
 The end of the chart made closer to the y-axis as per requests 
 Added ability to set up and down colors for candlestick and bar charts 

 Boardview\Baskets 
 Linked with MM window (and thus, charts and T&S window as well) 

1. Changing symbol in linked MM window will highlight the symbol in 
Boardview if the symbol is present  

2. Clicking on a symbol on Boardview will change the symbol in the linked MM 
window  

 New fields – Change from Open, Change from Open%  
 Single click to edit disabled. Instead, you will need to double click to edit an existing 

symbol 



 New Basket Order Entry window (enable Boardview as a Trading Basket) 
1. Allows users to set TIF for the entire basket – including setting “AT OPEN” 

TimeInForce value 
2. Can choose most Graybox destinations and order types 
3. Can choose to offset price based on Last price, Close price or inside market 

(inside bid for sells and inside ask for sells). The offset can be % or absolute 
value. 

 Allows users to select multiple rows in basket and send orders only for those select 
(use CTRL+MOUSE click to select multiple rows) 

 Order Types 
 ARCA ALO (Add Liquidity Only) order type added 
 Added ROUQ, INET, IOCT and IOCX as EDGX and EDGX routing modes 
 Added MPM (Mid Point Match) as an EDGX route 
 Bug with EDGX-EDGX & EDGA-EDGA Routing Mode fixed. 
 Added ARCA ALO+MPL as an ARCA route  
 Allow users to configure their routing style for EDGX and EDGA orders (set EDGA 

and EDGX Routing Styles via Trading Options). Currently available options are 1. 
Routable (default) 2. Super Aggressive – Cross and Lock 3. Aggressive – Cross Only 

 Full 64-bit compatibility  
 The users running Windows 7 or Vista 64 bit operating system can use the separate 

64-bit installer. The 64-bit version of Graybox will NOT work with a 32-bit operating 
system. If in doubt, users should use the 32-bit version of Graybox that will run in 
both 32-bit and 63-bit OS environments. 

 New Market Clock Window 
 To enable this window, click on “View->Market Clock” from the main menu or 

context menu  
 Will display the current market time – regardless of the local machine time.  
 Will also display if the market is open or closed 

 New Messages Window 
 This window has been rewritten for better performance ] 
 This can be sorted by time column, ascending or descending  

 New KeymapConfig window 
 No new functionality – but this has been rewritten for 64 bit compatibility  

 Pref. and Listed Trading window 
 Added option to “Close On Send” 

 Log file management 
 All log files will be stored in the “logs” subfolder  
 A maintenance option to “Clean Log Files” has been added that will delete all log 

files older than 15 calendar days 
 Open Yahoo finance website via a hot key OR using the MM window context menu 
 Single click access to Web Blotters – The support for the legacy Blotter application has 

been removed. Instead, users can click on the Graybox context menu or main menu and 
click to “Blotter” to automatically open their web blotter. 

 

 Configurable Level1 Items  



 Users can choose which fields to display and the order in which it is displayed (From 
the MM window context menu, select Setup->Level1 Quotes->Configure Level1 
Items 

 Net Change % added as a new field 
 Support for Listed Exchange: This will allow hot keys to send orders to the correct listing 

exchange e.g. for NYSE ARCA listed stocks, the primary exchange Market order hot key will 
send the market order to ARCA and not to NYSE as earlier. 

 System menu (minimize and max buttons) added to the Messages window, Executions 
ticker, Market Clock, Positions Monitor, Hedges & Locates Monitor. This will allow users to 
minimize these window and these will be visible in the windows task bar as separate items. 
(Also, new icons added for these windows) 

 Thermograph removed from the Market Maker window 
 BATS Book enabled as default to the Market Maker window (Level2 display) 
 Will allow dynamic loading of BBSS Booths from the database via the logon server. If the 

logon server does not have the active list, it will load the default booths (all currently active 
booths). This will allow us to add new BBSS booths without having to build a new Graybox 
release. 

 Allow repeat behavior for ARROW keys (UP, DOWN, LEFT and RIGHT) if they are ONLY 
assigned to increment or decrement prices. If they are assigned to anything else (check 
Keyboard Config dialog for details on key assignment), the repeat behavior will be 
DISABLED. 

 A bug with the reconnect logic when one of the primary Marketdata servers goes down has 
been fixed. This issue could have caused a delay in reconnecting if the user was connected 
to a secondary setting when the reconnect was issued (and the primary settings were 
having problems at that time) 

 For backup quotes, the channels opened will be based on the user’s feed selection via 
Backup quotes e.g. if the user just wants BATS, only the BATS channel will be opened. 

 The loading of pending orders will be based on the server date and not the client date. [If 
installing this version during the middle of the trading day and the machine is not set 
to EST, please do so ONLY if there are no floating orders] 

 Problem with scrolling up and down (using hotkeys or mouse) symbols in the Market Maker 
Window fixed 

 Extra set of SuperECNKey added ( the keys need to be using KeyMapconfig and the delta 
value need to be set using Setup->SuperECNKey) 

 Position Dialog summary window now displays all currency fields in the correct format. 
 Logon server updates all configuration settings as and when the user makes changes in the 

front end. This will help in troubleshooting user connectivity issues 
 The disconnect timeout for non-functioning logon server reduced to about 12 secs 

 


